Navigate and Source Menu UI Spec

Author: Jan Rojcek

$Revision: 1.9 $
$Date: 2005/10/13 09:38:57 $

Changes: available in CVS

This is a specification for Navigate and Source main menu. In addition to introducing these two menus, this document specifies changes in ordering and naming of menu items in other menus. All affected menus and menu items have bold font in the figures below.

Note: This is not a complete specification of all menus in NetBeans IDE for promotion F. For changes in menus like Refactor or CVS look into the appropriate specs.

Figure: Main Menu Bar

| File | Edit | View | Navigate | Source | Refactor | Build | Run | CVS | Tools | Window | Help |
Figure: File Menu
| File |
--------
New Project...
New File...
----------------------------
Open Project...
Open Recent Project        >
Close Project
Open File...
----------------------------
Set Main Project           >
Project Properties
----------------------------
Save
Save All
Refresh All Files
----------------------------
Page Setup...
Print...
Print to HTML...
Figure: Edit Menu
| Edit |
--------
Undo
Redo
-----------------------------
Cut
Copy
Paste
Delete
-----------------------------
Find Selection
Find Next
Find Previous
-----------------------------
Find...
Replace...
Find Usages
-----------------------------
Find in Projects...
-----------------------------
Start Macro Recording
Stop Macro Recording
Figure: View Menu
| View |
--------
Editors                     >
Code Folds                  >
-----------------------------
Web Browser
Documentation Indicies      >
-----------------------------
Toolbars                    >
Show Editor Toolbar
Show Line Numbers
Figure: Navigate Menu (* - defines item not targeted for promotion F)
| Navigate |
------------
Go to Class...
*Go to File...
Go to Test
Go to Previous Document
----------------------------
Go to Source
Go to Declaration
Go to Super Implementation
----------------------------
Back
Forward
*Go to Last Edit Location
----------------------------
Go to Line...
Toggle Bookmark
Next Bookmark
Previous Bookmark
----------------------------
*Next Method
*Previous Method
----------------------------
Next Error
Previous Error
----------------------------
Select in Projects 
Select in Files
Select in Favorites
Figure: Source Menu
| Source |
----------
Override Methods...
Fix Imports
Surround With try-catch
----------------------------
Reformat Code
Shift Left
Shift Right
Comment
Uncomment
----------------------------
Code Completion
Parameter Tip
Insert Next Matching Word
Insert Previous Matching Word
Figure: Build Menu (next/previous error items were moved to Navigate menu)
| Build |
---------
Build Main Project
Clean and Build Main Project
-----------------------------
Generate Javadoc for Project
Compile File
-----------------------------
Stop Building
Figure: Tools Menu is no longer dynamic
| Tools |
---------
Create JUnit Tests...
Add to Palette...
-------------------------
Javadoc Index Search...
Auto Comment...
Apply Diff Patch...
Internationalize        >
-------------------------
Java Platform Manager
Library Manager
Server Manager
NetBeans Platform Manager
-------------------------
Module Manager
Update Center
-------------------------
Options
Figure: Window Menu
| Window |
----------
Projects
Files
Favorites
Output
Navigator
Properties
Palette
Runtime
Search Results
Find Usages Results
Refactoring Review
To Do
HTTP Monitor
Versioning
Inspector
Editor (used to be "Switch to Document")
Processes
Debugging               >
-------------------------
Close Window
Maximize Window
-------------------------
Clone Document
Close All Documents
Close Other Documents
Documents...

Project Features

About this Project

ui was started in November 2009, is owned by Jiří Kovalský, and has 44 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20160708.bf2ac18). © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close