Top
 
 
 

List of Shortcuts

Maya Venkatraman
Dec. 12th, 2001

 

Skip to Introduction to shortcuts section

Skip to: A B CD E F GH I J KL M N OP Q R ST U V WX Y Z 01 2 3 45 6 7 89 F1 F2 F3F4 F5 F6 F7F8 F9 F10 F11F12 Other-Editor

 


A - TableShiftCtrlAlt   
JLF X  Ctrl + A Select All
Netbeans      
Netbeans - editor X  Ctrl + A Select All
Netbeans Menu       
Windows  X  Ctrl + A Select All
SolarisCDE      
KDE X  Ctrl + A Select All

B - TableShiftCtrlAlt    JLF XCtrl + BBold Netbeans       Netbeans - editorX X Shift + Alt + BMove insert to bottom  XX  Shift + Ctrl + BExtend Selection to matching Brace Netbeans Menu   X Alt + BBuild Windows        SolarisCDE       KDE XCtrl + BAdd book mark for current location
 

Top
 


C - TableShiftCtrlAlt    JLF X  Ctrl + C Copy Netbeans

X

 

 

X

 

 Shift + Alt + C 

Ctrl + C

Stop Compile 

Copy

Netbeans - editor X  Ctrl + C Copy Netbeans Menu        Windows        SolarisCDE       KDE X  Ctrl + C Copy

Top
 


D - TableShiftCtrlAlt    JLF       Netbeans       Netbeans - editor X  Ctrl + DShift line left Netbeans - editorXX  Ctrl + Shift + DUncomment (Java Editor) Netbeans Menu   X Alt + DDebug Menu Windows        SolarisCDE       KDE      

Top
 


E - TableShiftCtrlAlt    JLFXCtrl + E Align Center Netbeans       Netbeans - editor X  Ctrl + EDelete Line  Netbeans Menu   X Alt + EEdit Menu Windows        SolarisCDE       KDE X  Ctrl + EMove to bottom most position in document.

Top
 


F - TableShiftCtrlAlt    JLF X  Ctrl + F Find Netbeans X  Ctrl + F Find Netbeans - editorXX  Shift + Ctrl + F Reformat Code Netbeans Menu   X Alt + F File Menu Windows        SolarisCDE       KDE X  Ctrl + F Find

Top
 


G - TableShiftCtrlAlt    JLF X  Ctrl + G Find Again Netbeans X  Ctrl + G Go to  Netbeans - editor X 

X

  Ctrl + G 

Alt + G 

Go to line 

Go to declaration

Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


H - TableShiftCtrlAlt    JLF X  Ctrl + HReplace Netbeans X  Ctrl + HReplace Netbeans - editorX X Alt + Shift + H Toggle highlight search. Netbeans Menu        Windows        SolarisCDE       KDE X  Ctrl + H Same as back space
 

Top
 


I - TableShiftCtrlAlt    JLF X  Ctrl + IItalics Netbeans

 

X

X

 

 

X

 

Ctrl + Shift + I

Alt + Shift + I

Import Project

Fast-Import (java editor)

Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


J - TableShiftCtrlAlt    JLF       Netbeans

X

 

X

X

  

Ctrl + Shift + J

Ctrl + J(s /e)

Insert Internationalized String

Start / stop macro editing

Netbeans - editor  X Alt + J Select Identifier Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


K - TableShiftCtrlAlt    JLF       Netbeans       Netbeans - editor
 
 

X


 
 

 

 

X

 Ctrl + K 

Alt +K 

Shift + Alt + K 

Previous matched word 

Jump to previous edit 

Jump to previous edit across windows

Netbeans Menu        Windows        SolarisCDE       KDE X  Ctrl + K Delete till end of line

Top
 


L - TableShiftCtrlAlt    JLF X   Align Left  Netbeans       Netbeans - editor


 
 

X


 
 

 

 

X

 Ctrl + L 

Alt +L 

Shift + Alt + L

Next matched word 

Jump to Next edit 

Jump to next edit across windows

Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


M - TableShiftCtrlAlt    JLF       NetbeansXX  Shift + Ctrl + M Set Project Main Class Netbeans - editorX 

 

 

X

 

 Shift + Alt + M 

Ctrl + M

Move Insert to Center 

Select next parameter

Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


N - TableShiftCtrlAlt    JLF X  Ctrl + NNew Netbeans

 

X

X

  Ctrl + N 

Ctrl + Shift + N

New 

New Project

Netbeans - editor       Netbeans Menu        Windows  X  Ctrl + NNew SolarisCDE       KDE X  Ctrl + NCreate a New Document

Top
 


O - TableShiftCtrlAlt    JLF X  Ctrl + OOpen Netbeans

 

X

 


 
 

X

 Ctrl + O 

Ctrl + Shift + O 

Shift + Alt + O

Open  File

Open Project 

Go to Class

Netbeans - editor  X Alt + O Go to Source (java editor) Netbeans Menu        Windows  X  Ctrl + OOpen SolarisCDE       KDE X  Ctrl + OOpen

Top
 


P - TableShiftCtrlAlt    JLF X  Ctrl + PPrint Netbeans X  Ctrl + PPrint Netbeans - editor       Netbeans Menu   X Alt P Project Menu Windows  X  Ctrl + PPrint SolarisCDE       KDE X  Ctrl + PPrint

Top
 


Q - TableShiftCtrlAlt    JLF       Netbeans       Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE X  Ctrl + QQuit Application

Top
 


R - TableShiftCtrlAlt    JLF X  Ctrl + R Align Right Netbeans       Netbeans - editor X??  Ctrl + R Replace Netbeans Menu   X Alt + R Versioning Menu Windows        SolarisCDE       KDE X  Ctrl + R Find and replace matches

Top
 


S - TableShiftCtrlAlt    JLF X  Ctrl + SSave NetbeansXX 

X

  Ctrl + S 

Ctrl + Shift + S

Save 

Save Project 

Netbeans - editor       Netbeans Menu        Windows  X  Ctrl + SSave SolarisCDE       KDE X  Ctrl + SSave

Top
 


T - TableShiftCtrlAlt    JLF       Netbeans       Netbeans - editorX 
 
 

X

 

X

X

 

  Shift + Alt + T 

Ctrl + T

Ctrl + Shift + T

 

Move Insert to Top 

Shift line right

Comment in selection(java editor)

Netbeans Menu   X Alt + TTools Menu Windows        SolarisCDE       KDE      

Top
 


U - TableShiftCtrlAlt    JLF X  Ctrl + U Underline Netbeans       Netbeans - editor X  Ctrl + U Delete Previous Characters in a line    X Alt + U ( B, T ,M ,E ,R ,L ,U) Move Scroll Insert to Top, bottom, center end of word + switch case , to lower , to upper Netbeans Menu        Windows        SolarisCDE       KDE X  Ctrl + U Delete from start of line 

Top
 


V - TableShiftCtrlAlt    JLF X  Ctrl + VPaste Netbeans X  Ctrl + VPaste Netbeans - editor X  Ctrl + VPaste Netbeans Menu   X Alt V View Menu Windows  X  Ctrl + VPaste SolarisCDE       KDE X  Ctrl + VPaste

Top
 


W - TableShiftCtrlAlt    JLF X  Ctrl + WClose Netbeans       Netbeans - editor X  Ctrl + WDelete Word Netbeans Menu   X Alt + WWindow Windows        SolarisCDE       KDE XCtrl + WClose

Top
 


X - TableShiftCtrlAlt    JLF X  Ctrl + XCut Netbeans X  Ctrl + XCut Netbeans - editor X  Ctrl + XCut Netbeans Menu        Windows  X  Ctrl + XCut SolarisCDE       KDE X  Ctrl + XCut

Top
 


Y - TableShiftCtrlAlt    JLF X  Ctrl + YRedo Netbeans X  Ctrl + YRedo Netbeans - editor X  Ctrl + YRedo Netbeans Menu        Windows  X  Ctrl + YRedo SolarisCDE       KDE      

Top
 


Z - TableShiftCtrlAlt    JLF X  Ctrl + Zundo Netbeans X  Ctrl + Zundo Netbeans - editor X  Ctrl + Zundo Netbeans Menu        Windows  X  Ctrl + Zundo SolarisCDE       KDEXX 

X

  Ctrl + Z 

Shift + Ctrl + Z

undo 

Redo

Top
 


0 - TableShiftCtrlAlt    JLF       Netbeans X   Explore from here Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


1 - TableShiftCtrlAlt    JLF       Netbeans X  Ctrl + 1Properties Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


2 - TableShiftCtrlAlt    JLF       Netbeans X  Ctrl + 2Explorer Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top


 


3 - TableShiftCtrlAlt    JLF       Netbeans X  Ctrl + 3 Source Ed. Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top


 


4 - TableShiftCtrlAlt    JLF       Netbeans X  Ctrl + 4Output Window Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


5 - TableShiftCtrlAlt    JLF       Netbeans X  Ctrl + 5Debugger Window Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


6 - TableShiftCtrlAlt    JLF       Netbeans X  Ctrl + 6Exec. Window Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


7 - TableShiftCtrlAlt    JLF       Netbeans X  Ctrl + 7 Web Browser Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


8 - TableShiftCtrlAlt    JLF       Netbeans X  Ctrl + 8Component inspector Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


9 - TableShiftCtrlAlt   JLF      Netbeans X Ctrl + 9Object browser. Netbeans - editor      Netbeans Menu       Windows       SolarisCDE      KDE     

Top
 


F1 - TableF1ShiftCtrlAlt   JLFX 

X

X
 
 

X

 F1 

Shift + F1 

Ctrl + F1

help 

contextual help 

Displays or dismisses tool tip

NetbeansX 

X

X

 X

 


 
 

X

F1

Shift + F1

Alt + F1

help 

Javadoc Index Search

Go to Help (java editor)

Netbeans - editor       Netbeans Menu        Windows        SolarisCDEX 

X

X  f1 

Shift + f1

Help 

context sensitive Help

KDEX   F1Help

Top
 


F2 - TableF2ShiftCtrlAlt   JLFX   F2Enable editing in a table cell Netbeans       Netbeans - editorX

X

 

X

  F2 

shift + F2

Next bookmark 

Prev. bookmark

Netbeans Menu        Windows X   F2Rename a selected item SolarisCDEX 

X

X  F2 

Shift + F2

Displays overview of each action in help window 

Displays online ed. info (in help window only)

KDEX   Alt + F2Open mini command-line window 

Top


 


F3 - TableF3ShiftCtrlAlt   JLF       Netbeans       Netbeans -editorX 

X

X
 
 

X

 F3 

Shift + F3 

Ctrl + F3

Find next 

Find previous. 

Find selection

Netbeans Menu        Windows X   F3Desktop find SolarisCDE       KDEX 

X

X
 
 

 


 
 

X

F3 

Shift + F3 

Alt + F3

Find next 

Find previous. 

Window operation menu 

Top


 


F4 - TableF4ShiftCtrlAlt   JLFX X Ctrl + F4Closes internal window that has keyboard focus  NetbeansX 

X

 X F4 

Ctrl + F4

Run to cursor 

Close

Netbeans - editor       Netbeans Menu        Windows X 

X

 X 

 

X

F4 

Ctrl + F4 

Alt + F4

Opens drop down list box on the toolbar 

Close active document. 

Close

SolarisCDEX  XAlt + F4Close KDEX  XAlt + F4Close

Top
 


F5 - TableF5ShiftCtrlAlt   JLFX

X

X

 
 
 

X

 F5
 
 

Ctrl + F5

Refresh
 
 

Opens min. win that has focus(NetBeats touse enter)

NetbeansX

X

X

 


 
 

X

 Alt + F5

Shift + F5 

Ctrl + F5 

Ctrl + Shift +F5

Start debug

Finish 

Continue 

Debug project

Netbeans - editor       Netbeans Menu        Windows X   F5Refresh SolarisCDEX

X

   F5

Alt + F5

Refresh now

Restore

KDE      

Top
 


F6 - TableF6ShiftCtrlAlt   JLF

X

 

X

 

 

X


 
  X 

F6

 

Shift + F6 

Shift + Ctrl + F6

Navigate between split panes. (Netbeans to use Ctrl + Shift + Tab - to be done))

Navigate - internal. window. 

Navigate  - internal. window. (use above)

NetbeansX

X

 

 

X

 F6

Ctrl + Shift +F6

Execute

Execute project

Netbeans - editor       Netbeans Menu        Windows X

X

 

 

X

 F6

Ctrl + F6

Moves between panes in help.

Switch to next MDI child window.

SolarisCDEX 
 
 

X

  
 
 

X

F6 
 
 

Alt + F6 

Move cursor in CW direction from one window pane to the next 
 
 

Move input focus to next window within the window family 

KDE      

Top
 


F7 - TableF7ShiftCtrlAlt   JLFX X Ctrl + F7Moves internal window. NetbeansX 

X

X

 

 

X

X

 

X

 

X

 

X

 

F7 

Alt + shift + F7

Ctrl + Shift + F7

 

Step into 

Step out

Add Watch

 

Netbeans - editor       Netbeans Menu        Windows        SolarisCDEX  XAlt + F7 Move KDE      

Top
 


F8 - TableF8ShiftCtrlAlt   JLFX 

X

 X F8 

Ctrl + F8

Gives focus to splitter bar 

Resizes internal window

NetbeansX 

 

X


 

X

 F8 

Shift + F8

Shift + Ctrl + F8

Step over 

Toggle Break Point 

Add BreakPoint

Netbeans - editor       Netbeans Menu        Windows XX  Shift + F8Move without selecting in extended selection list boxes  SolarisCDEX 

X

  X 

X

At + F8 

Shift + F8

Allows user to change the size of window 

Toggle out of keyboard add mode when extended selection is provided for a view. 

KDE      

Top
 


F9 - TableF9ShiftCtrlAlt   JLFX X Ctrl + f9 Minimizes internal window NetbeansX 

 

X

X


 
X


 
 
 

F9

Shift + F9 

Ctrl + Shift + F9 

Compile 

Compile All 

Compile Project 

Netbeans - editor       Netbeans Menu        Windows        SolarisCDEX 

X

  X 

X

F9 

Alt + F9 

Alt + F9 

Keyboard help in help window 

Hide 

Minimize

KDE      

Top
 


F10 - TableF10ShiftCtrlAlt   JLFX

X

X  F10

Shift + F10

Moves focus to menu bar and posts first menu.

Displays Contextual Menu

NetbeansXX

X

 Shift + F10Popup menu Netbeans - editor       Netbeans Menu        Windows        SolarisCDEX 

X

 

X

  F10

Shift + F10

Move cursor to menu bar 

In a popup window, displays help information that describes how to use the help.

KDE      

Top
 


F11 - TableF11ShiftCtrlAlt   JLF       NetbeansX 

 

X

X


 
X


 
 
 

F11

Shift + F11 

Ctrl + Shift + F11 

Build

Build All 

Build Project 

Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 


F12 - TableF12ShiftCtrlAlt   JLF       NetbeansX 

X

X

X

 

X

X

 

 

 

X

 

 

 

 

X

F12 

Shift + F12

Ctrl + Shift + F12

alt + F12

Next Error 

Previous Error 

Work place Explorer

Focus to splitter bar (To be done)

Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      

Top
 
 


[ - Table[ShiftCtrlAlt   JLF       Netbeans

 

 X 

Ctrl + [

Match Brace

Netbeans - editor       Netbeans Menu        Windows        SolarisCDE       KDE      


[ - Table\ShiftCtrlAlt   JLF       Netbeans

 

      Netbeans - editor  X 

Ctrl + \

Show code completion

Netbeans Menu        Windows        SolarisCDE       KDE      
Space BarSpacebarShiftCtrlAlt   JLFX

X

 X

 

 Ctrl + SpaceBar

Spacebar

Displays contextual menu in MDI

Activates command button that has keyboard focus (in dialog boxes or toolbar) 

Makes a selection and deselects any previous selection (in list box)

Turns on radio button

Switches toggle button on or off.

Netbeans       Netbeans - editorX

X

 X Shift + Spacebar 

Ctrl + Spacebar

Reset Abbreviation 

Show Completion

Netbeans Menu        Windows X
 
 

X
 
 

X

 
 
 

X
 
 

X

XAlt + Spacebar
 
 

Spacebar 
 
 

Ctrl + Spacebar

Open program Menu from the left most icon on the title bar of the active window. 

Selects or deselects current item in extended list

Selects or deselects current item in extended list

SolarisCDE       KDE      

T


Other NetbeansShortcuts  Crtl + Enter Evaluate Alt + LeftPrevious View Alt +Right Next View Ctrl + Shift + Up Focus Previous Workspace Ctrl + Shift + DownFocus Next Workspace Ctrl + Alt + Up Go to called Method Ctrl + Alt + Up Go to calling MethodCtrl + Shift + Tab Navigate between split panes (To be done)


 




Other Editor ShortcutsIn Netbeans EditorIn JLF Shift + SpaceReset Abbreviation.   Alt + Shift + B Move Insert to Bottom  Alt + Shift + MMove Insert to Center  Alt + Shift + TMove Insert to Top  Alt + U + BScroll Insert to Bottom  Alt + U + MScroll Insert to Middle  Alt + U + TScroll Insert to Top  left , Left arrow (np)Insert point backMove left one char  Ctrl + Home Insert point to beginning of documentMove to start of text area  HomeInsert point to beginning of lineMove to start of line  Down , arrow (NP) Insert point down (1 line) Move down one line  Ctrl + EndInsert point to the end of the documentMove to end of text area  End
Insert point to the end of the line
Move to end of line  Alt + U EInsert point to the End of the word  Right +Arrow(NP)Insert point to right ?Move right one char  Ctrl + Right Insert point to next wordMove to next word  Ctrl + LeftInsert point to previous wordMove to previous word  UpInsert point upMove up one line  Ctrl + SpaceCompletion Show  Shift + Delete Cut  DeleteDelete next characterDelete next character  Backspace, Shift + BackDelete previous. CharacterDelete previous character  EscapeSimulates escape  EnterInsert New LineInsert line break  TabInsert tabInsert tab  Page Down Page DownBlock move down  Page up Page up Block move up Shift + TabDelete Tab does not work yet Ctrl UpScroll UpBlock move left Ctrl Down Scroll DownBlock move right Shift + Left Extend Selection BackwardsExtend selection left Ctrl + Shift + HomeExtend Selection back to beginning of the documentExtend selection to start of text area  Shift + HomeExtend selection to beginning of lineExtend selection to start of line  Shift + DownExtend selection downExtend selection down  Ctrl + Shift + EndExtend selection to end of documentExtend selection to end of text area  Shift + endExtend selection to end of lineExtend selection to end of line  Shift + RightExtend Selection forwardExtend selection right  Ctrl + Shift + RightExtend Selection to next wordExtend selection to next word  Shift + Pg. Dn.Extend selection to next pageBlock extend down Shift + Pg. UpExtend selection to previous pageBlock extend up  Ctrl + Shift + LeftExtend selection back one wordExtend selection to previous word  Shift + UpExtend Selection upExtend selection up  Shift + EnterSubstitute Code Completion  Insert Toggle Typing Mode Ctrl + Insert Insert  Shift + InsertPaste 

NOTEs - KDE uses F1--8 to move to different workspaces -

 GNOME shortcuts have not yet been standardized

For keyboard characters that do not have a table on this page , please consult listed sources or send email to the UI Team.

 

Introduction to Shortcuts

What are Keyboard Shortcuts

(Source - JLF design guidelines)

Keyboard shortcuts are keystroke combinations that activate a menu item from the keyboard even if the menu for that command is not currently displayed. Keyboard shortcuts usually consist of a modifier key and a character key, like Control-Z, plus a few special keys such as F1 and Delete. Unlike mnemonics, keyboard shortcuts do not post menus; rather, they perform the indicated actions directly. Since all keyboard shortcuts are available at all times, you cannot reuse them as you do mnemonics.

Guidelines for Keyboard Shortcuts

(Source - JLF design guidelines)

 

 

Sources



Navigation

Project Features

About this Project

ui was started in November 2009, is owned by Jiří Kovalský, and has 37 members.

NetBeans.org

By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20140418.2d69abc). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close