.NET2Java UI Specification

Author: Jindrich Dinga
Version: First draft
Last Update: 02/06/06

Content

  1. Introduction
  2. UI design
    1. Project importer
    2. .NET Library Manager

1. Introduction

This feature is designed to import a .NET project written in C# or VB to Java platform.

For more information click here. If you want to see some Before&After results, click here.

2. UI design

2.1. Project importer

To start importing a C# or VB project a user must simply choose C# Project... or VB Project... in menu File | Import Project (see figure 1).

figure 1 - File menu

After choosing the type of the project a wizard appears (see figure 2). By filling out these fields

Project to Import - the user must specify where the original project is located
Destination Folder - the user must specify where the project will be imported (the user can also write a name of a folder which does not exist - then the folder is created)
Select Project Type - the user must specify the type of the project - in this section, the .NET names of project types are used:

  1. Console Application - Command line
  2. Windows Application - GUI
  3. ASP. NET Application - Web

Select Main Class - the user must select from given classes which class is the main
Set as main Project - the user can check off this option, if s/he does not want to set this project as main. This option is checked on by default.

the Finish button is enabled.

figure 2 - "Import C# Project" wizard

After pressing the Finish button, importing of the project begins - a modal dialog appears (see figure 3). In this dialog, the progress bar is displayed; its label displays the name of the project being imported and the detailed information, e.g. Importing MyClass.cs.

figure 3 - "Importing Selected Project" dialog

If the translator does not find a syntax, which could not deal with, the progress indication dialog disappear and the imported project is opened in the Project view, otherwise a syntax error report appears (see figure 4). This modal dialog shows places where syntaxes, which were not translated, are located. The untranslated syntaxes are marked as FIXMEs and are displayed in To Do window (see figure 5), which is automatically opened after pressing the OK button.

figure 4 - "Unknown Syntax Found" dialog

figure 5 - To Do window

2.2. .NET Library Manager

If the user does not want to always translate the unknown syntaxes by hand, but wants to create/modify the translation libraries, s/he must invoke .NET Library Manager which is located in menu Tools (see figure 6 ).

figure 6 - Tools menu

After invoking the Library Manager, a non-modal dialog appears (see figure 7a-b ).

figure 7a - Class Mapping tab- .NET Library Manager

figure 7b - Member Translation tab - .NET Library Manager

In the .NET Import Library Manager in the Class Mapping tab, when the user pressses the Browse... button, behind the Super Type Name text field, a modal dialog appears (see figure 8a). In this dialog, the user can choose a class which will become the super class; classes are ordered alphabetically. Similar dialog appears after pressing the Browse... button behind the Java Class Name text field (see figure 8b).

figure 8a - Member Translation tab - .NET Library Manager
figure 8b - Member Translation tab - .NET Library Manager

To add a property, method or an event, the user must click on Add... button in Member Translation tab, then a modal dialog opens (see figure 9a-c). After openning the "Add" dialogs, the fields are pre-filled with appropriate text.

figure 9a - "Add Property" dialog
figure 9b - "Add Method " dialog


figure 9c - "Add Event" dialog

Project Features

About this Project

ui was started in November 2009, is owned by Jiří Kovalský, and has 44 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20160708.bf2ac18). © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close