Maximization and Full Screen Mode UI Specification

Author: Jindrich Dinga
Date: April 2006
Version: Final

Content:

  1. Introduction
  2. UI Specification
    1. Maximization mode
    2. Full Screen mode
    3. Other behavior
  3. Sub Groups

1. Introduction

Users often complain that they cannot use palette in the design mode when the editor is maximized. There are also another issues regarding to the maximized editor. This feature should solve mentioned issues.

In this UI spec we will use the following terms:

Default mode: The IDE starts in this mode, e.g. for the first time the IDE starts with open Projects, Files, Runtime window, Navigator and Welcome screen.
Maximized mode: Window covers all space within the IDE in this mode.
Full Screen mode: By invoking this mode, the IDE loses its title bar and covers all screen. In addition to that, menu bar stays visible and tool bars are disabled.
Windows Group: Windows that are related to a mode (e.g. windows group for Form file consists from Inspector/Navigator, Properties and Palette).
Sub group: Sub group is a set of predefined windows that are opened in maximized mode. Windows in a sub group are opened just in case the user did not close them or slide them into the edge bar. Sub group is a part of Windows group.

To see use cases and scenarios for this feature, please click here.

2. UI Specification

2.1. Maximized mode

According to the use cases, we have to distinguish between two states of editor:

  1. Editor is not maximized
  2. Editor is maximized

In these two states, maximizing of windows is same:

A window can be maximized by selecting Maximize Window action in Window menu, invoking same action from the contextual menu on title bar/tab, double clicking on title bar/tab or using the "Shift+Escape" shortcut on Windows platform (this shortcut can vary on different platforms). The maximized window covers all space within the IDE.

The difference between these two states is in canceling of the maximized window. When Editor is not maximized, canceling of the maximized window causes the IDE goes to the default mode. In case of maximized Editor, canceling of the maximized window causes that the maximized Editor is visible. Canceling the maximized Editor brings the IDE to default mode.

Another difference is in behavior of a window that gives focus to another window (e.g. Output window gives focus to Editor): it does not matter whether the Output window is maximized or not, because it always gives focus to Editor in current state. It means

  • Editor is not maximized
    • Output window is maximized - gives focus to Editor that it is not in maximized mode
    • Output window is not maximized - gives focus to Editor that it is not in maximized mode
  • Editor is maximized
    • Output window is maximized - gives focus to Editor that it is in maximized mode
    • Output window is not maximized - gives focus to Editor that it is in maximized mode

To get rid of the maximized window, select Restore Window menu item in Window menu, invoke same action from the contextual menu on title bar/tab, double click on title bar/tab or use "Shift+Escape" shortcut on Windows platform (this shortcut can vary on different platforms). The IDE goes to the default mode.

Please note, in the following flash interactive movie double click is replaced by single click. In addition to that, all windows, that are present in this prototype, can be invoked from Window menu.

flash 1 - Flash interactive movie

The logic behind:

  • After maximizing editor, all windows that are not in a sub group with maximized editor are slid to the edge bar; windows in the sub group stay docked.
  • Windows in a sub group are docked only in maximized mode if they were not slid to the edge bar in the default mode before invoking the maximized mode for the first time (E.g. the user creates a GUI application. In Default mode she slides the Palette to the edge bar. Then she invokes the Maximized mode for the first time where the Palette even if it is in the sub group stays in the edge bar - the Palette takes the initial state).
  • New sub groups can be easily created/modified by opening/docking/sliding windows; changes in sub groups are persistent.
  • New window, that is not present in Maximized mode, opened by the user appears in the edge bar and slides out. In case newly opened window was not present in Default mode, that window appears as docked window there.
  • A window that is closed in Maximized/Default mode is also closed in Default/Maximized mode.
  • If a window is moved to different place in any mode, the position of that window is changed in every mode.
  • Window in slide mode can be also maximized, however docked windows are not slid to the edge bar; canceling the maximized mode brings the window to its previous size.
  • Resizing of a maximized window that is in sliding mode by dragging the window's edge cancels the maximized mode of that window.
  • Every window located in an edge bar, has own size.

When the editor is maximized, windows that are in the sub group stay docked other windows are slid to the edge bar. After maximizing the editor a separator appears (separator appears exactly on same position as editor's edge when a window is slid to the edge bar) for the purpose of distinguishing between buttons in the edge bar and the editor with its sub group. In addition to that a background color appears. This behavior is valid for all platforms except Macintosh where maximized editor with its sub group appear in a box. For details about the visualization click here.

The following section describes position of maximize/restore buttons in the editor for Windows XP L&F only. Icons for other L&Fs are available in the zip file.

Maximize
Restore
normal state
mouse over state
pressed state
normal state
mouse over state
pressed state
N/A
N/A

Tool tips for buttons above are: "Maximize Window" and "Restore Window".

2.2. Full Screen mode

Full Screen mode is available only in menu View | Full Screen or via "Ctrl+Alt+Enter" shortcut on Windows platform ("Cmd+Alt+Enter" on Mac platform). Being in Full Screen mode means that the IDE loses its title bar and covers all screen. In addition to that, menu bar stays visible and tool bars are disabled by default. To cancel this mode, the user can use already mentioned shortcut or go to View menu and uncheck "Full Screen" menu item.

The windows layout in Full Screen mode depends on windows layout the IDE had before. For example, the user creates a GUI application; the IDE is in Default mode. The user invokes Full Screen mode - the IDE loses its title bar, menu bar stays visible and tool bars are disabled, the windows layout is still same like in Default mode. Then the user maximizes the editor, the IDE is still in Full Screen mode. After canceling the Full Screen mode, the IDE gets its title bar, menu bar and tool bars back, the windows layout stays same - Editor is still maximized in this case.

The following picture shows position of Full Screen menu item in View menu as well as its shortcut and mnemonic (figure 1). The "Full Screen" is check box menu item.

figure 1 - View menu (Full Screen mode is not enabled)

The following flash movie shows Full Screen mode in action.

flash 2 - Flash movie

2.3. Other behavior

The IDE always starts in Default mode (with or without maximized editor) - no Full Screen mode after starting the IDE.

3. Sub Groups

The following modes are for default NetBeans Installation only. Other installed modules can create new modes with new sub groups.

Mode
Sub Group
Creating GUI applications, writing a code

Palette

Debugging
Watches, Local Variables, Call Stack

 

Project Features

About this Project

ui was started in November 2009, is owned by Jiří Kovalský, and has 37 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20140418.2d69abc). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close