Use Cases and Scenarios for Maximization and Full Screen Mode

Author: Jindrich Dinga with contribution of Stanislav Aubrecht, Rudolf Bock and Dusan Pavlica
Date: April 2005
Version: Final

Content:

  1. Maximization Mode
    1. Use Cases
    2. Scenarios
  2. Full Screen Mode
    1. Use Cases
    2. Scenarios
  3. UI Specification

1. Maximization Mode

1.1. Use Cases

The user needs to

UC-1. maximize a window in order to see all information contained in the window
UC-2. maximize editor to get more space for working

1.2. Scenarios

In following scenarios let's suppose that Project view, Navigator, Inspector, Editor (a form, Java and XML files), Palette, Properties and Output window are opened and docked in the IDE. Let's call this state as default.

UC-1.1: User checks the results in a window and invokes an action

  1. user invokes maximize action by double clicking on e.g. Output window title bar/using shortcut/selecting this action from contextual menu or from Window menu
  2. Output window is maximized (covers all space within the IDE) - Project view, Navigator, Inspector, Palette and Properties are slid to the edge bar, Editor becomes invisible (hidden behind the maximized window)
  3. by selecting an error link in Output window, Output window is slid to the edge bar, Editor becomes visible and the error link gets focus
  4. by double clicking on maximized window's title bar/using shortcut/selecting "Restore" action from contextual menu or from Window menu, the maximized mode is canceled - the IDE goes back to default

UC-1.2: User checks the information in a window, then s/he cancels the maximization

  1. user invokes maximize action by double clicking on e.g. Output window title bar/using shortcut/selecting this action from contextual menu or from Window menu
  2. Output window is maximized (covers all space within the IDE) - Project view, Navigator, Inspector, Palette and Properties are slid to the edge bar, Editor becomes invisible (hidden behind the maximized window)
  3. by double clicking on the title bar/using shortcut/selecting "Restore" action from contextual menu or from Window menu, the maximized mode is canceled - the IDE goes back to default

UC-1.3: User checks the information in a window, then s/he docks another window

  1. user invokes maximize action by double clicking on e.g. Project view title bar/using shortcut/selecting this action from contextual menu or from Window menu
  2. Project view is maximized (covers all space within the IDE) - Navigator, Inspector, Palette, Properties and Output window are slid to the edge bar, Editor becomes invisible (hidden behind the maximized window)
  3. user opens e.g. Files window, this window appears as a toggle button in the edge bar and slides out of the edge bar, then s/he docks this window
  4. by
    • double clicking on Project view title bar/using shortcut/selecting "Restore" action from contextual menu or from Window menu, the maximized mode is canceled - the IDE goes back to default
    • double clicking on Files window title bar/using shortcut/selecting "Maximize window" action from contextual menu or from Window menu the Files window is maximized
  5. by double clicking on Files window title bar/using shortcut/selecting "Restore" action from contextual menu or from Window menu, the maximized mode is canceled - the IDE goes back to default

UC-2.1: User works in maximized editor, then s/he cancels the maximization

  1. user invokes maximize action by double clicking on an Editor tab (a form file)/using shortcut/selecting this action from contextual menu or from Window menu
  2. Editor is maximized (covers all space within the IDE) - Project view, Navigator, Inspector, Properties and Output window are slid to the edge bar, Palette is docked (is in sub group)
  3. user selects e.g. Java file - Project view, Navigator and Output window stays in edge bar, Properties, Inspector and Palette disappear
  4. by double clicking on Editor tab/using shortcut/selecting "Restore" action from contextual menu or from Window menu, the maximized mode is canceled - the IDE goes back to default, however Java file is focused in Editor so Inspector, Properties and Palette are not present in the IDE, just Project view, Navigator and Output window are docked
  5. by selecting the form file, Inspector, Properties and Palette are visible again

UC-2.2: User works in maximized editor and docks a window

  1. user invokes maximize action by double clicking on an Editor tab (a form file)/using shortcut/selecting this action from contextual menu or from Window menu
  2. Editor is maximized (covers all space within the IDE) - Project view, Navigator, Inspector, Properties and Output window are slid to the edge bar, Palette is docked (is in sub group)
  3. user needs e.g. Properties for working so s/he docks this window
  4. double click on Properties title bar/using shortcut/selecting "Maximize window" action from contextual menu or from Window menu the Properties window is maximized
  5. another double click on Properties title bar/using shortcut/selecting "Restore" action from contextual menu or from Window menu cancels maximized mode of Properties window
  6. double click on Editor tab/using shortcut/selecting "Restore" action from contextual menu or from Window menu cancels maximized mode of Editor - the IDE goes back to default
  7. another maximizing of Editor (a form file) invokes same set and position of windows (in this case Palette and Properties)

2. Full Screen Mode

2.1. Use Cases

The user needs to

UC-1. work within the IDE without being disturbed by another applications

2.2. Scenarios

UC-1.1: User does not want to be disturbed by another applications

  1. user invokes full screen mode by using shortcut/selecting this action in View menu
  2. in full screen mode the IDE covers all screen as well as loses its title bar, menu bar and main tool bar
  3. after using the shortcut or pressing the Esc button this mode is canceled
  4. the IDE goes back to the mode that had before

3. UI Specification

For UI Specification, click here.

Project Features

About this Project

ui was started in November 2009, is owned by Jiří Kovalský, and has 44 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20160708.bf2ac18). © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close