Output Window Specification

Author: Josef Pavlicek

$Revision: 1.26 $
$Date: 2007/03/06 13:05:04 $

Content

 

Requirements

Motivation

Motivation of this specification is to improve process run signalization in the Output window. If the user starts some java application, he is not able to stop it in the output window. He/she has to go to Runtime window -> select processes -> click by right button of mouse and than terminate the process. If the user works with IDE, especially if he/she uses the output window, he/she wants to have more functions for controlling of the java application.

 

Goals

To improve design and behavior of the Output window.

 

Output window UseCases

For detail UseCases of Output Window please click here.

 

Output window variants

During the process of build of this specification I prepared a lot of models and design drafts. If you want, you can see them in the file OutputWindowVariants.hml (click here) .

 

 

NetBeans output window behavior and design

Current output window design and behavior

Now the output widow shows all messages(Figure 1) from build, run and finish (stop) java application. The user can slide the window into the edge bar, this window can be in the sliding mode. The user can close the window by the close icon in the top right corner of the window tab.

Figure 1: Current output window design and behavior

 

Output window behavior

If the user starts some action like Run file, Run project, Build project etc. the system shows the output window. This output window should have toolbar placed in the edge. On this toolbar should be placed icons. These icons should allow:

  • to repeat the last action
  • stop application
  • to allow the user to filter the outputs shown in the output window

 

New output window toolbar

Into the left side of the output window we can add tool bar. This tool bar has width 26 pix's and his height is resizable with the window. The background color of the toolbar depends on Operation System. This color has to be similar like status line background color. In Windows XP is the color 236,233,216 (Figure 2). The color of toolbar edge lines (on XP line has 127,157,185 color) depends on Operation System too. For Metal L&F for example, has to be the color different according to Metal L&F.

Figure 2: Vertical toolbar

 

Toolbar behavior and appearance

New toolbar has:

  • re-run button
    • if the user clicks on this button, the system repeats the last action, which called the output window. It is:
      • Build project
      • Clean and build project
      • Run project/file
      • Clean project
      • Generate java doc for project
    • for other actions (action which open special window) like:
      • Debug project/file
      • Test project
      • etc. are not buttons on toolbar defined and the system doesn't show them (Figure 2) in the toolbar
  • stop (terminate) application button
    • after the click on this button the system stops the running application(the output window is still visible)
  • filter button
    • by default is the filter switch on. The system shows messages:
      • from running application - System.out.println(""), Exceptions etc. The system doesn't show ANT messages like "build successful" etc.
      • if the code has some error (and shows where the error is)
    • if the user switch off the filter, the system shows all messages according to main IDE settings - Tools->Options->ANT->Verbosity level.
    • filter button has on the right down corner the pointer icon. If the user clicks on it the system shows him/her the menu (Figure 7.1, Figure 7.2)
      • Activate for all tabs
        • This function is switch on by default. Means = > Activate this function (Filter OF or Filter OFF) for ALL tabs in the output window
      • Activate for this tab only
        • Means = >Activate this function (Filter OF or Filter OFF) only for this tab.
    • Filter button remembers its setting for each project or java file, according to users setting. This setting is valid under the user:
      • changed it (switched the filter button)
      • deletes the project or file
    • Filter button is Switch ON by default (this functionality is common for all new tabs in output window).
      • NetBeans has to have this option placed in Tools -> General -> Advanced Options -> Options -> Window -> Output
        • The user can Switch OFF filter button here. After that all new tabs will have filter button Switched OFF
    • If the user switches the filter during the application runs, the changes are visible immediately but system doesn't changes the lines that were already printed

Close window or selected tab is realized by the cross located in the tab of output window (Figure 4) or in the tab (Figure 5)

Position and proportions of toolbar buttons

  • If is only one running application in the output window, the position of re-run button is:
    • the frame around the close button Figure 3 (which is visible on mouse over etc.) is:
      • 1 pixel from left
      • 1 pixel from right
      • 1 pixel from down line of output window tab(or from down line of next top button) (Figure 3)
  • If are in the output window open more tabs, the position of edge re-run button and top output window line is 33 pixels (Figure 5, Figure 6 ).

 

Figure 3: Appearance and positions of toolbar buttons

Figure 4: Vertical toolbar buttons position

Figure 4.1: Close and stop application cross on the tab

If are in the output window more tabs, the right and down edge line of the toolbar has similar color like the line around the selected tab. It is 145,155,156.

Figure 5: Example of more running applications in one output window

Figure 6 : Design of more tabs in output window if the toolbar is visible for first opened tab

Design of output window toolbar buttons

The re-run button and stop button (Figure 4) are standard system buttons (has similar color like system buttons by non active, mouse over and pressed state) like for example the buttons for controlling the run of application server (Figure 9). If the

  • Re-run button icon (has tooltip - "Re-run")
  • Stop application button icon (has tooltip - "Stop")
  • Filter button icon
    • filter button is toggle button. (Figure 7)
      • if is switch on has white background and icon of filter doesn't changes the color- (has tooltip Filter-on)
      • if is switch off has color like the toolbar background and icon doesn't changes the color (has tooltip Filter-off)
        • if the user switches the filter during the application runs, the changes are visible immediately but system doesn't changes the lines that were already printed
          • the changes are active for active tab only
            • the filter settings (which the user changed in toolbar) is active only for particular java application while the user
              • changes the filter settings (switches off/on)
              • remove (delete) the application from IDE NetBeans
          • other tabs or new running applications have filter button switched according to system settings in:
            • NetBeans has to have this option placed in Tools -> General -> Advanced Options -> Options -> Window -> Output

Figure 7 - detail of filter button (switched on)

 

 

DOWNLOAD ICONS

 

Toolbar buttons appearance during the application runs

Figure 8: The re-run button or stop button has gray color if is non - active

  • Re-run button is gray, if the application runs
  • Stop button is gray, if the application doesn't run

 

 

 

Redesign of server console toolbar

The new design of Output window means some changes in the Server console.

  • The width of toolbar is 26 pixels (Figure 2). This size has Re-factoring toolbar too. Server console toolbar is bigger. For consolidation of output window design is good to make the server console toolbar smaller (26 pixels width).
  • To change particular background color of server console toolbar on the system color (on XP is it236,233,216) (Figure 2) The color has to be similar like status line color.
  • To add blue line on the right edge of the toolbar. The color of the line is similar like color of tab edge lines (on XP is it 145,155,156). The color depends on Operation System too.

NOTICE: Between Run in Debug Mode and Re Run buttons should be Start In profile Mode button . For more information, contact profiler team.

Figure 9: Redesign of Server console

 

 


Contact:

Ing. Josef Pavlicek, Ph.D.
Human Interface Designer
Software eXperience Design
Sun Microsystems Czech s.r.o

Phone:+420 233 009 442
GSM: +420 737 38 54 75
E-mail: Josef.Pavlicek@Sun.Com

 


 

Project Features

About this Project

ui was started in November 2009, is owned by Jiří Kovalský, and has 43 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20160708.bf2ac18). © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close